17hats Email Server (SendGrid - 3rd Party) Service Interruption
Incident Report for 17hats
Resolved
This incident has been resolved.
Posted May 14, 2019 - 09:39 PDT
Monitoring
A fix has been implemented by SendGrid and we are monitoring the results.
Posted May 14, 2019 - 09:16 PDT
Identified
We have received notice from our third-party email service, SendGrid, that they are experiencing a service interruption, which they are working to fix quickly.

Temporarily Affected Services:
- 17hats notification emails (you’ve paid an invoice! You have a new lead!)
- Multi-user invitation emails (when you are adding a new user within your 17hats account)
- Password Reset emails
- Anyone using the 17hats server as their Outgoing Email Server will see that their emails have been successfully sent in 17hats, however, the Server, SendGrid, has yet to successfully send these out.

IMPORTANT NOTE: Once SendGrid restores this service, they will then send any back-logged/unsent emails, so there will be no need for 17hats users to re-send emails in the interim; this could cause duplicate emails to be received by customers if they are additionally re-sent from within 17hats or other email inboxes separately.
Posted May 14, 2019 - 08:39 PDT
This incident affected: SendGrid SMTP.